Auteur Topic: Lambdasonde voorverwarming controleren (foutcode 5-2-1)  (gelezen 3217 keer)

0 leden en 1 gast bekijken dit topic.

volvobug

  • Wat anderen bedacht hebben moet ik op z'n minst kunnen begrijpen!
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 5677
  • Geslacht: Man
  • V70 2.5 10v '97 LPi & V70R FWD AUT Saffron '98 LPi
    • Volvo foto album
Lambdasonde voorverwarming controleren (foutcode 5-2-1)
« Gepost op: 14-12-2009 23:32:35 »
Er is al veel geschreven over de 5-2-1 foutcode en de mogelijke oorzaken. Heb dan ook al veel gecontroleerd maar nog nooit de sonde zelf. Deze er gisteren maar eens uitgeschroefd en de voorverwarmingsdraden rechtstreeks aan de 12 volt gehangen.

Nou veronderstel ik dat die in een paar seconden 600-700 graden zou moeten zijn. Normaal zou de ECU door de massa te pulseren dit ongeveer op 700 graden houden.

Maar bij mijn sonde, na ca 10 seconden een nauwelijks voelbare temperatuurstijging, misschien was het zelfs wel schijn. Het strijkijzer thuis warmt in ieder geval sneller op.

is het juist te stellen dat de voorverwarming van de sonde zo te testen is, en dat in dit geval de code 5-2-1 inderdaad het probleem met de voorverwarming zou kunnen zijn?

« Laatst bewerkt op: 24-12-2009 16:41:23 door volvobug »
Handtekening? 85011806 en Saffronie.

razorx

  • Lijnoliekoning
  • Polar lid
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 11978
  • Geslacht: Man
  • V70N 2003-417
    • van automatisering die stopt naar automatisering die klopt
Re: Lambdasonde voorverwarming controleren
« Reactie #1 Gepost op: 15-12-2009 01:14:04 »
Er is al veel geschreven over de 5-2-1 foutcode en de mogelijke oorzaken. Heb dan ook al veel gecontroleerd maar nog nooit de sonde zelf. Deze er gisteren maar eens uitgeschroefd en de voorverwarmingsdraden rechtstreeks aan de 12 volt gehangen.

Nou veronderstel ik dat die in een paar seconden 600-700 graden zou moeten zijn. Normaal zou de ECU door de massa te pulseren dit ongeveer op 700 graden houden.

Maar bij mijn sonde, na ca 10 seconden een nauwelijks voelbare temperatuurstijging, misschien was het zelfs wel schijn. Het strijkijzer thuis warmt in ieder geval sneller op.

is het juist te stellen dat de voorverwarming van de sonde zo te testen is, en dat in dit geval de code 5-2-1 inderdaad het probleem met de voorverwarming zou kunnen zijn?


Nee,

Je moet het zo zien: Een lambda sonde is geen soldeerbout. Is dus niet bedoeld om warmte naar buiten te voeren.
Je hebt het, als ik het goed lees, netjes gedaan door de sonde niet te lang te verwarmen.

Wat je beter kan doen is met een ohm meter de voorverwarmingsdraden door te meten.

Maar pas op, meet niet met en ohm meter aan de signaaldraden. Je meetspanning kan te hoog zijn voor de sonde.
Die krengen zijn wat overgevoelig. ;)

Dan eindigt het met een lapzwanszonde.

volvobug

  • Wat anderen bedacht hebben moet ik op z'n minst kunnen begrijpen!
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 5677
  • Geslacht: Man
  • V70 2.5 10v '97 LPi & V70R FWD AUT Saffron '98 LPi
    • Volvo foto album
Re: Lambdasonde voorverwarming controleren
« Reactie #2 Gepost op: 15-12-2009 10:32:56 »
OK, kan er dus niet mee solderen, jammer  :(

De voorverwarming heb ik ohms gemeten, waarde was ongeveer 5 a 5,5 Ohm weerstand. Iemand enig idee of dit juist is?

Handtekening? 85011806 en Saffronie.

KIM

  • Global Moderator
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 10638
  • Geslacht: Man
  • 850 R Estate AT LPI, V70 XC Estate AT LPI
Re: Lambdasonde voorverwarming controleren
« Reactie #3 Gepost op: 15-12-2009 10:55:05 »
Klinkt als een hoge waarde.
Levert een stroom op van 12/5 = 2,2 A ongeveer

Zou eerder hopen op een waarde van 1 a 2 ohm

razorx

  • Lijnoliekoning
  • Polar lid
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 11978
  • Geslacht: Man
  • V70N 2003-417
    • van automatisering die stopt naar automatisering die klopt
Re: Lambdasonde voorverwarming controleren
« Reactie #4 Gepost op: 16-12-2009 01:56:16 »
OK, kan er dus niet mee solderen, jammer  :(

De voorverwarming heb ik ohms gemeten, waarde was ongeveer 5 a 5,5 Ohm weerstand. Iemand enig idee of dit juist is?


Inderdaad bij die lage impedanties kan je een mogelijke meetfout van ongeveer 0,5 ohm hebben.

Je volgende test is het meten van de spanning over de opwarmweerstand van de sonde. Bij net gestarte motor.
Ja naar meten op die plek. ;)
Alleen de eerste paar seconden wordt er opgewarmd, meen een seconde of 12 maar ik kan me vergissen.
Dus meteen meten.

Staat er keurig een Volt of 13 op, dan is je sonde toch wat te hoog ohmig. En aan vervanging toe.
Is het een lagere waarde wordt het een lastiger verhaal.

volvobug

  • Wat anderen bedacht hebben moet ik op z'n minst kunnen begrijpen!
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 5677
  • Geslacht: Man
  • V70 2.5 10v '97 LPi & V70R FWD AUT Saffron '98 LPi
    • Volvo foto album
Re: Lambdasonde voorverwarming controleren
« Reactie #5 Gepost op: 24-12-2009 15:00:17 »
Ik heb me het nare meten kunnen besparen. Vond het bij nader inzien niet onverstandig na 250K km de sonde eens te vervangen. Dus eentje besteld en vandaag maar even gewisseld.

En ja hoor, na het resetten van de 5-2-1 code blijft het milieulampje tot dusverre uit  :eusa_dance:. Het was in dit geval dus wel een "harde" kwestie van "voorverwarming lambdasonde" niet OK.

Heb nu ook het idee dat bij de koude start waarbij de motor de eerste 1 a 2 minuten op benzine draait (LPi auto), de regeling veel fijner is, merkbaar aan een rustigere loop. Eigenlijk ook wel logisch, de sonde is immers na een paar seconden op temperatuur om dan zijn werk goed te kunnen doen. Met de defecte sonde had ie daar waarschijnlijk een paar kilometer voor nodig, maar dan was er al weer omgeschakeld naar gas.

Ik zal op het Onderdelen en prijzen topic even een post doen over de sonde. Dank voor alle tips.

Oja, nu ik de oude sonde weer uit de auto heb nog maar eens de ohmse waarde gemeten van de voorverwarming. Meet inmiddels oneindig.

--edit-- Oneindig blijkt toch meetbaar, namelijk 155 Mega-ohm. Ook niet goed.
« Laatst bewerkt op: 24-12-2009 16:42:32 door volvobug »
Handtekening? 85011806 en Saffronie.

razorx

  • Lijnoliekoning
  • Polar lid
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 11978
  • Geslacht: Man
  • V70N 2003-417
    • van automatisering die stopt naar automatisering die klopt
Re: Lambdasonde voorverwarming controleren
« Reactie #6 Gepost op: 24-12-2009 15:06:16 »
Mooi dat je er uit bent!
Het eerste verval van onze sondes begint al bij 150dkm, vanaf dan worden ze langzaam slechter.
Ik verwacht dat je brandstofverbruik ook gunstiger zal worden, na inleren door de ecu.

volvobug

  • Wat anderen bedacht hebben moet ik op z'n minst kunnen begrijpen!
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 5677
  • Geslacht: Man
  • V70 2.5 10v '97 LPi & V70R FWD AUT Saffron '98 LPi
    • Volvo foto album
Re: Lambdasonde voorverwarming controleren
« Reactie #7 Gepost op: 24-12-2009 15:17:04 »
Hoop ik ook, we zullen het zien.
Handtekening? 85011806 en Saffronie.

thuur

  • Thuurbo Fivespoke
  • Global Moderator
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 24143
  • Geslacht: Man
  • \/olvo'\/7O.T5 \/olvo'85O.T~5
    • thuurbo
Re: Lambdasonde voorverwarming controleren (foutcode 5-2-1)
« Reactie #8 Gepost op: 24-12-2009 23:15:23 »
Heb nu ook het idee dat bij de koude start waarbij de motor de eerste 1 a 2 minuten op benzine draait (LPi auto), de regeling veel fijner is, merkbaar aan een rustigere loop. Eigenlijk ook wel logisch, de sonde is immers na een paar seconden op temperatuur om dan zijn werk goed te kunnen doen. Met de defecte sonde had ie daar waarschijnlijk een paar kilometer voor nodig, maar dan was er al weer omgeschakeld naar gas.

Dat is correct. Een oude lambdasonde kan slechts heel traag reageren. Vaak hoor je de motor dan ook 'zagen' tijdens stationair met een frequentie van ca. 1 Hz of lager.


Gr 8)

razorx

  • Lijnoliekoning
  • Polar lid
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 11978
  • Geslacht: Man
  • V70N 2003-417
    • van automatisering die stopt naar automatisering die klopt
Re: Lambdasonde voorverwarming controleren (foutcode 5-2-1)
« Reactie #9 Gepost op: 25-12-2009 01:09:13 »
Heb nu ook het idee dat bij de koude start waarbij de motor de eerste 1 a 2 minuten op benzine draait (LPi auto), de regeling veel fijner is, merkbaar aan een rustigere loop. Eigenlijk ook wel logisch, de sonde is immers na een paar seconden op temperatuur om dan zijn werk goed te kunnen doen. Met de defecte sonde had ie daar waarschijnlijk een paar kilometer voor nodig, maar dan was er al weer omgeschakeld naar gas.

Dat is correct. Een oude lambdasonde kan slechts heel traag reageren. Vaak hoor je de motor dan ook 'zagen' tijdens stationair met een frequentie van ca. 1 Hz of lager.


Gr 8)
Ik kan hier nog wat aan toevoegen: Bij de 20V heb ik de lambdasonde ooit vervangen door een imi exemplaar.
Delphi-Lockheed, zou niet al te beroerd moeten zijn zou je hopen.

Al rijdende lijkt het alsof er niets aan de hand is.

Door mijn VVIS tuning project was ik genoodzaakt een reeks AFR metingen te doen. Wat reageert dat imi ding traag ten opzichte van origineel.

Met name de goede werking van de MAF of MAP sensor en de lambdasonde zijn essentieel om de ECU de motor goed aan te laten sturen.
« Laatst bewerkt op: 25-12-2009 01:11:15 door razorx »

volvobug

  • Wat anderen bedacht hebben moet ik op z'n minst kunnen begrijpen!
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 5677
  • Geslacht: Man
  • V70 2.5 10v '97 LPi & V70R FWD AUT Saffron '98 LPi
    • Volvo foto album
Re: Lambdasonde voorverwarming controleren (foutcode 5-2-1)
« Reactie #10 Gepost op: 27-12-2009 23:30:33 »
Misschien iets te vroeg gejuichd. Lampje is nog steeds uit, maar de auto loopt niet goed, of hopelijk, NOG niet goed. Heb deze post al opgesnord,

http://www.volvo850forum.nl/index.php/topic,35451.0.html,

mijn problematiek is nu identiek, zij het dat die zich pas na ca 120 km na vervanging is begonnen  :'(

Lambdasonde donderdag gewisseld, alleen maar even stationair laten draaien en blokje om. Alles prima, lampje uit, foutkode weg. Gisteren pas de eerste serieuze rit gemaakt, 100 km heen en later 100 km terug. Heenweg alles OK. Terugweg, op de snelweg, begint auto  met 120-130 km/uur in te houden gedurende een seconde of 20-30, om daarna weer te gaan acceleren. Dit bleef zich de hele weg herhalen. Als ik terugschakelde om hoger in de toeren te komen (> 3200 ongeveer) pakte hij weer op om lekker door te trekken, in de 5de versnelling, 130 aanhouden en jawel hoor, gaat een half minuutje of ze goed en dan zakte hij weer terug. Mijn vriendin merkte het zelfs door te vragen of het gas op was, zo'n effect was er. Stationair loopt hij beroerd, zakt terug tot 600-700 toeren en lijkt of er een cylinder niet meeloopt. Gas bij geven heeft pas na 5-10 seconden effect, komt er bijna niet door heen.

Probleem is er zowel op gas als op benzine. Onsteking dus verdacht. Geen foutcodes.

Vandaag maar eens e.e.a. gecontroleerd:
- alle vacuumslangetjes en knietjes OK
- gasklephuis gereinigd (incl 2 kleine gaatjes onderin).
- Verdeler, rotor en bougiekabels geinspecteerd (juli 2008  nog alles vervangen): OK.
- met lopende motor bougiekabels 1 voor 1 los, geen effect.


Heb de bougies eruit gehad, hebben hun beste tijd zo te zien wel gehad. ECU ook een kwartier losgehad van de accu, kan die lekker helemaal opnieuw gaan leren.

Stap 1: morgen nieuwe bougies halen en plaatsen.
Stap 2: geduld hebben volgens de link hierboven

Nog andere suggesties?


Handtekening? 85011806 en Saffronie.

pwassink

  • Universeel-Techneut
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 4295
  • Geslacht: Man
  • 850 nee nie meer & Glad & Groenig is gaan hemelen.
Re: Lambdasonde voorverwarming controleren (foutcode 5-2-1)
« Reactie #11 Gepost op: 27-12-2009 23:37:04 »
je schrijft : - Verdeler, rotor en bougiekabels geinspecteerd (juli 2008  nog alles vervangen): OK.

Even later meld je dat de bougies hun beste tijd hebben gehad ..

hoeveel Km heb je onderhand met die verdelerkap, rotor en bougiekabels gereden ?

En is indertijd ook de kabel vd bobine <> verdelerkap gewisseld ?

Op gas heb je gewoon een 100% optimale onsteking nodig, dat hij op benzine ook al minder loopt geeft helemaal te denken.
wel even nadenken hou oud die benzine ondrhand is en of je daar regelmatig even op rijdt.





Fouten moet je niet gaan herhalen, dat hindert evolutie 🙂

volvobug

  • Wat anderen bedacht hebben moet ik op z'n minst kunnen begrijpen!
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 5677
  • Geslacht: Man
  • V70 2.5 10v '97 LPi & V70R FWD AUT Saffron '98 LPi
    • Volvo foto album
Re: Lambdasonde voorverwarming controleren (foutcode 5-2-1)
« Reactie #12 Gepost op: 28-12-2009 00:02:54 »
Verdelerkap-rotor-bougiekabels zitten er nu zo'n 65.000 km in. Ik heb de verdeler-rotor vorig jaar op vakantie op de gok vervangen, gaf geen problemen maar moest toen iets (zie evt. http://www.volvo850forum.nl/index.php/topic,27913.msg556103.html#msg556103).

De vorige originele kabels hebben het 180K. km goed gedaan voordat ze in de kop begonnen door te slaan.
Ik zal ze niet uitsluiten maar vooralsnog zijn ze wat mij betreft "minder verdacht". Behalve kabel bobine-verdelerkap, daarvan moet ik even opzoeken of ik die gewisseld heb. Goede tip.

Auto start altijd op benzine, en ik tank per maand zo'n 15 tot 20 liter benzine nieuw. Lijkt me wel voldoende toch?



Handtekening? 85011806 en Saffronie.

pwassink

  • Universeel-Techneut
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 4295
  • Geslacht: Man
  • 850 nee nie meer & Glad & Groenig is gaan hemelen.
Re: Lambdasonde voorverwarming controleren (foutcode 5-2-1)
« Reactie #13 Gepost op: 28-12-2009 00:18:07 »
Verdelerkap-rotor-bougiekabels zitten er nu zo'n 65.000 km in. Ik heb de verdeler-rotor vorig jaar op vakantie op de gok vervangen, gaf geen problemen maar moest toen iets (zie evt. http://www.volvo850forum.nl/index.php/topic,27913.msg556103.html#msg556103).

De vorige originele kabels hebben het 180K. km goed gedaan voordat ze in de kop begonnen door te slaan.
Ik zal ze niet uitsluiten maar vooralsnog zijn ze wat mij betreft "minder verdacht". Behalve kabel bobine-verdelerkap, daarvan moet ik even opzoeken of ik die gewisseld heb. Goede tip.

Auto start altijd op benzine, en ik tank per maand zo'n 15 tot 20 liter benzine nieuw. Lijkt me wel voldoende toch?





Vwb bougies, ik wissel deze t liefst per 10/15K zo ongeveer, met een iets getweakte turbo op gas dan weer voor volvo "longlife" kaarsjes

Vwb die kabel tussen bobine en verdeler, staat vast wel een jaartal op (als t volvo is)  meen dat je deze apart moet bestellen
wordt nog wel eens vergeten, vandaar de tip ..

Benzine zou op zich fris genoeg moeten zijn op deze manier ..  flesje injectorcleaner zou niet verkeerd zijn misschien .


Na de kaarsjes (en of bobinekabel-wissel) eerst op benzine alles tiptop maken, dan zou gas t ook goed moeten kunnen doen,
je hebt geen foutcodes verder ? (los van die 5-2-1 dan uiteraard .. )
« Laatst bewerkt op: 28-12-2009 00:20:44 door pwassink »
Fouten moet je niet gaan herhalen, dat hindert evolutie 🙂

volvobug

  • Wat anderen bedacht hebben moet ik op z'n minst kunnen begrijpen!
  • Lid 1000+
  • *****
  • Offline Offline
  • Berichten: 5677
  • Geslacht: Man
  • V70 2.5 10v '97 LPi & V70R FWD AUT Saffron '98 LPi
    • Volvo foto album
Re: Lambdasonde voorverwarming controleren (foutcode 5-2-1)
« Reactie #14 Gepost op: 29-12-2009 09:48:45 »
Misschien iets te vroeg gejuichd. Lampje is nog steeds uit, maar de auto loopt niet goed, of hopelijk, NOG niet goed. Heb deze post al opgesnord,

http://www.volvo850forum.nl/index.php/topic,35451.0.html,

mijn problematiek is nu identiek, zij het dat die zich pas na ca 120 km na vervanging is begonnen  :'(


Heb gisteren met 2x75 km met de auto op de snelweg gereden en goed geanalyseerd. Probleem niet helemaal identiek.
Wat er gebeurt is dat de auto vanaf de koude start prima rijdt, totdat je op snelheid op de snelweg een constante snelheid aanhoudt. Als je dan ook maar iets van het gas gaat (even "liften") dan begon het gedonder. Inhouden gedurende een seconde of 15-30 om dan weer op te pakken. Heb het met verschillende constante snelheden geprobeerd. Steeds hetzelfde beeld, acceleren OK, constant houden OK, even liften en ja hoor, inhouden.....  Eenmaal van de snelweg, afwisselend beroerd stationair lopen.

Handtekening? 85011806 en Saffronie.